Excel tips and tricks
· To freeze rows and or columns at the top or left of your workbook so that headings stay in place while you scroll down or across the worksheet. Place your cursor at the intersection of the rows/ columns you want fixed in place, then:
· Go to View tab > Freeze panes > Freeze panes
· Color code tabs to organize
· Right click over tab, select Tab Color, then select color desired
· Avoid slow scrolling or super scrolling
· Ctrl+End
· Go to the bottom cell of the column(s) you want to highlight
· Ctrl+Shift+Home
· Arrow over left or right, depending on which columns you want

Base Data Tab
· Formatting cells – custom formats
· Example: Column A: Student ID – 6 digits: 000032
· Right click over cell(s), select Format Cells
· Custom
· Type: 000000
· Date as 20250327
· Right click over cell(s), select Format Cells
· Custom
· Type: YYYYMMDD
· Get rid of extra leading or ending spaces
Column F FORMULA: =TRIM(B2)
· Calculate Age
· Need another cell or column with comparison dates
· Column I FORMULA: =ROUNDDOWN(YEARFRAC(G2,H2),0)
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· Absolute References – Locks which columns and/ or rows you are pulling from. This is essential to working with formulas in Excel. Use the F4 tip:
· F4 If you’re editing a cell and the cursor is in between the cell references it will insert the $ signs for absolute references. Repeated pressing F4 will scroll through different levels of absolute references: locks both column and row, then just row, then just column, then back to none.


· VLOOKUP
· From coding key (use when you do something over and over again)
· Examples include: listing order of variable, Award, CIP code, division
FORMULA Column L: =VLOOKUP($K2,'Coding Key'!$A:$B,2,FALSE)
Looks up data from column K (Race Ethnicity) to Coding Key, locking columns A & B, column 2 (Ethnicity order)
· From other databases
· Important: Make sure you put the data you will be joining in the same Excel workbook, in a different tab; linking across workbooks is problematic and often links get broken
Column M FORMULA: =VLOOKUP($A2,HS!$A:$C,2,FALSE)
	Looks up data from Student ID on HS tab, column 2 (HS name)
Column N FORMULA: =VLOOKUP($A2,HS!$A:$C,3,FALSE)
	Looks up data from Student ID on HS tab, column 3 (HS grad year)
***If you get an error (because the student isn’t on the other tab), you have 3 options:
=IFERROR(VLOOKUP($A2,HS!$A:$C,2,FALSE),“No HS”)
Use this if need to see text or know there are no awards, etc.
=IFERROR(VLOOKUP($A2,HS!$A:$C,2,FALSE),0)
Use this if need a number to come back, such as credit hours
=IFERROR(VLOOKUP($A2,HS!$A:$C,2,FALSE),“”)
Use this if need the cell to be blank, as it affects other formulas tied to this column
Column O FORMULA: =VLOOKUP($A2,'Credit hours'!$A:$B,2,FALSE)
Here you would want the return to be a zero, so would add IFERROR
=IFERROR(VLOOKUP($A2,'Credit hours'!$A:$B,2,FALSE),0)
Looks up data from Student ID on Credit hours tab, column 2 (Sum of credit hours)
Column P FORMULA: =IF(O2>=11.5,"FT","PT")
Calculates if a student is full-time or part-time
Column Q FORMULA: (will come back to)
=IFERROR(VLOOKUP($A2,'Undup awards'!$A:$F,6,FALSE),"No awards granted")
Looks up from Student ID on the Undup awards tab, column 6 (completed first year)


Create Pivot Table from Base Data
· Have to be clicked within the data cells; if you are in a chunk of blank cells, you will have to move your cursor
· Important: Make sure all columns have a title and there are no blank columns in between data; otherwise it will not let you create a pivot table
· Click on the Insert tab in the top ribbon
· Click Pivot Table > From Table Range
· Should automatically select whole table; if it doesn’t, can click on the up arrow and select the correct cells
· Should automatically select New worksheet; if it doesn’t, change from Existing to New Worksheet
· Click OK.
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· Rename tab to pivot base
· Right click on tab and click on rename OR
· Double left click on tab and it will let you type the new name
· Go to the Design tab in the top ribbon
· Select Report Layout > Show in Tabular Form
· On the right side, under PivotTable fields, grab Student ID and drag it down to Values
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· It automatically does Sum of Student ID if it’s a number; if it’s a text variable, it will do count of variable
· To change from Sum, left click on Sum of Student ID and select Value Field Settings
· Change from Sum to Count
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· 
· If you want to change the format, click Number Format in the bottom left-hand corner
· Select Number, click on Use 1000 Separator (,) and change to 0 decimal places
· Click Ok
· Click Ok again
NOTE: Can use currency, or percentage and select # of decimals as appropriate 
· Click on variable or grab and drag to rows
· Example: Race Ethnicity 
· Pull Ethnicity Coded to the left of Race Ethnicity on the left-hand side OR move it around in the Rows section on the right-hand side
· Left click on the arrow down button on the Ethnicity Coded variable
· Select Sort AZ
· ALWAYS check if coding is correct!!!
· Ethnicity coded > Race Ethnicity
· FA24 CCC enroll status > Credit hours this term
· If need subtotal, right click in the column you want a subtotal and click Subtotal
[image: ]

[image: ]
· Can use filters too

To update PivotTable:
· Click PivotTable Analyze tab in top ribbon > Refresh > Refresh all
Use anytime you update data or formulas or grab more data within database



Create Chart
· Click in pivot table
· Go to the Insert tab in the top ribbon
· Click on Recommended charts (or specific chart you want)
· Most common:
· Clustered column
· 100% stacked column
· Pie
· Clustered bar
· 100% stacked bar
· Can do it to the same tab or new tab, depending on data
· If don’t like the chart and need to change it to something else, go to the Design tab in the top ribbon and click Change Chart Type
· To add data labels to chart
· Right click over chart and click Add data labels
· Click on data labels, change font color to black and type to Arial, Bold, 10pt
· To put outlines around the data pieces
· Right click over chart and click Format data series
· Left click on the paint can, expand out Border, click on Solid line, change color to black, change Width to 0.75pt
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· If want to add percents with the numbers, right click over the numbers > Format data labels
· Under Label Options
· Click on Value from Cells
· Select the data in the % column (not the total, just the lines)
· Then you have to click on box beside Value from Cells again
· If you go down to Separator, you can change to a semicolon or new line, depending on what chart you are doing
Awards-Text to columns tab
· Text to columns
· Example: Major; Do text to column to split out award, alpha, spec1, spec2
· Copy LOA column (column B); paste in column J
· Highlight column J
· Go to Data tab at the top
· Click on Text to Columns
· Delimited > Next
· Other _ > Next
· Click Finish
· NOTE: If Course Number like: MATH*0980*CGF23 and change the column with 0980 from General to Text (to keep the 0900 courses, otherwise loses the leading 0)
· Highlight column K
· Go to Data tab at the top
· Click on Text to Columns
· Delimited > Next
· Other . > Next
· Click Finish
· Fix column titles appropriately
· Column H: Add Cohort variable IF Statements 
· FORMULA: 
=IF(J2="AA","1. 2 yr degree",
IF(J2="AS","1. Degree",
IF(J2="ADN","1. Degree",
IF(J2="AAS","1. Degree",
IF(J2="DIP","2. Diploma",
IF(J2="CER","3. Certificate",
IF(J2="CERT","3. Certificate","No")))))))
NOTE: ALT+ENTER forces a hard carriage return in a cell instead of wrapping the text –while editing the cell. This makes the data within an Excel cell to put it on separate line without being on a separate row. Can do with both formulas and text.

· Column I: Another option for Cohort variable with IF/ OR statements
· FORMULA: 
=IF(OR(J2="AA",J2="AS",J2="ADN",J2="AAS"),"1. Degree",
IF(J2="DIP","2. Diploma",
IF(OR(J2="CER",J2="CERT"),"3. Certificate","No")))
· Column G: Time frame
· FORMULA: =IF(F2<=$R$1,"Before June 2024","After June 2024") 
· If LOA date is less than or equal to the set date in R1, then returns Before June 2024, if not, it will return After June 2024
· Important to lock the R1 cell with $ before each so when you copy down the formula, it won’t change the row
· Column E: Formatting cells – custom formats
· Date as 20250327
· Right click over cell(s), select Format Cells
· Custom
· Type: YYYYMMDD
· Column C FORMULA: Program
=VLOOKUP($K2,'Coding Key'!$D:$F,2,FALSE)
Look up column K – Alpha to Coding Key tab, columns D through F lock ($D:$F), pull column 2, program name
· Column D FORMULA: CIP Code
=VLOOKUP($K2,'Coding Key'!$D:$F,3,FALSE)
Look up column K – Alpha to Coding Key tab, columns D through F lock ($D:$F), pull column 3, program name; that’s why we put a $ in front of K, so could copy formula and just change 2 to 3 (column)



Create PivotTable from Awards tab
· Click Pivot Table > From Table Range
[image: ]

· Copy data, from bottom to top, excluding total line and line 3
· Create new tab, rename: Undup awards
· Paste data on new tab
· Add Column F Highest Award Completed
FORMULA:
=IF(B2>0,"1. Completed degree",
IF(C2>0,"2. Completed dip",
IF(D2>0,"3. Completed cert""")))
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· Then go back to Base data tab, Q2
=IFERROR(VLOOKUP($A2,'Undup awards'!$A:$F,6,FALSE),"No awards granted")



Course data tab
· Column B FORMULA: Concatenate – join together data in multiple columns
=CONCAT(C2,"*",D2)
=CONCATENATE(C2,”_”,E2,"_",F2,"_",G2)
· Shorten data/ pull data out of cell
· Column E FORMULA: Pull out the alpha out of column D, first 4 characters
=LEFT(D2,4)
· Column F FORMULA: Pull out the course number of column D, go 6 characters in and then take the next 4 characters
=MID(D2,6,4)
· Column G FORMULA: Pull out the section number out of column D, from the right, the last 5 characters
=RIGHT(D2,5)
· Formula
· Column I FORMULA: Passed Classify grades into groups of Passed C+, Passed D_D+, and Not passed 
=IF(OR(H2="A",H2="A+",H2="B",H2="B+",H2="C",H2="C+",H2="P"),"Passed C+",
IF(OR(H2="D",H2="D+"),"Passed D_D+",
IF(H2="","No grade","Not Passed")))
· Column J FORMULA: Passed credits C+ If category in column I is passed, then pull the data from the credits column (K)
=IF(I2="Passed C+",K2,"")

Convert to Range tab
To make a table not a table
· Click in the table
· Select the Table Design tab at the top
· Click on Convert to Range
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Other Helpful Items
· Format Sheet Tab Colors – Right-Click mouse on Sheet Tab > Tab Color
· Transpose Data – Copy data > Paste Special > Transpose
· Convert formulas to values - Copy cells containing formulas > Paste Special > Paste Values.
· Copy formulas only – Copy cell containing formula you want to copy > Paste Special > Paste Formulas.
· Print titles on each page automatically – On the Page Layout tab of the ribbon select Print Titles. This will open the Page Setup dialog box. Enter your rows and or columns you want repeated in the boxes highlighted below by clicking in the box and then clicking on the row or column header on your worksheet.
Keyboard Shortcuts:
· CTRL+Z Uses the Undo command to reverse the last command or to delete the last entry that you typed.
· CTRL+ Opens the insert cells/ columns/ rows dialog box
· CTRL-  Opens the deletes cells/ columns/ rows dialog box
· ALT= Inserts a SUM formula.
· CTRL+S Saves workbook.
· CTRL+C Copy
· CTRL+X Cut
· CTRL+V Paste
· CTRL+F Opens the Find dialog box
· CTRL+H Opens the Find & Replace dialog box
· CTRL+HOME Quickly move to home. If you have frozen panes your cursor will stop at the intersection of the frozen panes.
· END key then Up or Down, or Left or Right Arrows OR the CTRL+Up Arrow/Down Arrow etc. Move to end of a range of cells (column or row). Your selected cell will stop at any empty cell in the range, or if cells are empty it will stop at the next populated cell in the column or row.
· CTRL+TAB Switches between open Excel windows.
· CTRL+A Selects entire worksheet
· CTRL+1 Displays the Format Cells dialog box.
· CTRL+K Opens the Hyperlink dialog box
· CTRL+N Opens a new workbook
· CTRL+P Opens Print dialog box.
· CTRL+Page Up or CTRL+Page Down Scroll between worksheets
· CTRL+D copies the cell above. Select a range or row and then CTRL+D to copy the row.
· CTRL+` View formulas instead of values (note the ` shares the tilde ~ key)
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